Topic-icon Ladezeiten Ergebnisse

4 Monate 1 Woche her #12428 von Reaperman
Hallo zusammen,

ich hatte auf meiner Testumgebung eine Version vom JSM vom 15.04.17.....dort lief der Aufbau der Ergebnisseiten gut und zügig.
Nachdem ich heute die Neuste Version aus dem GIT installiert habe, dauert es gefühlte Ewigkeiten und auch das resultranking funktioneirt nicht mehr.
Wenn ich auf den Reiter Tabelle klicke, zeigt er mir keine Tabelle mehr an, sondern bleibt bei den Ergebnissen....

fs5.directupload.net/images/170713/f6kghhza.jpg
fs5.directupload.net/images/170713/vtbl73na.jpg

Ist dieses ein Bug oder kann ich das irgendwie beeinflussen?

Grüße
Reaperman

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

4 Monate 4 Tage her #12433 von diddipoeler
Wie lautet denn die Internetseite ?
Wurde bootstrap installiert ?
Ansonsten bitte die Adminzugangsdaten an mich senden.
Folgende Benutzer bedankten sich: Reaperman

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

4 Monate 2 Tage her #12434 von dei71
Hallo,

das mit den Ladezeiten kann ich bestätigen.

Kann man das nicht so einstellen, das man verschiedene Sachen abschalten kann? Treffpunktzeiten, ID-Nummern etc. Theorretisch bräuchte, jetzt auf mich bezogen, Datum, Zeit, Spiele und Ergebnisse.

LG Dirk

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Monate 3 Wochen her #12462 von Reaperman

diddipoeler schrieb: Wie lautet denn die Internetseite ?
Wurde bootstrap installiert ?
Ansonsten bitte die Adminzugangsdaten an mich senden.


Hallo diddi,

habe gesehen das Du was im GIT gearbeitet hattest. Tabbele in der Ansicht funktioniert wieder. Nur die Ladezeiten sind immer noch extrem. Ich hatte dir einen Zugang eingerichtet und dir das vor einigen Tagen per PN geschickt. :-)

Grüße
Reaperman

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Monate 1 Woche her #12581 von Reaperman

diddipoeler schrieb: Wie lautet denn die Internetseite ?
Wurde bootstrap installiert ?
Ansonsten bitte die Adminzugangsdaten an mich senden.


Hallo zusammen,

ich habe mir das Problem einmal genauer angeschaut. Das Problem liegt in der Datei /components/com_sportmanagement/models/project.php.
Ich habe geschaut was in meiner und der neueren Versionen für Unterschiede sind.

if ( !self::$_project && COM_SPORTSMANAGEMENT_SHOW_DEBUG_INFO )
{
$app->enqueueMessage(JText::_(__METHOD__.' '.__LINE__.' seasonid<br><pre>'.print_r(self::$seasonid,true).'</pre>'),'Error');
$app->enqueueMessage(JText::_(__METHOD__.' '.__LINE__.'<br><pre>'.print_r($db->getErrorMsg(),true).'</pre>'),'Error');
}


}
Zeile 373-> //$db->disconnect(); // See: api.joomla.org/cms-3/classes/JDatabaseDr...ml#method_disconnect
return self::$_project;
}

Ich habe die Zeile 373 auskommentiert und seitdem werden die Ergebnisse wieder super schnell angezeigt. Vielleicht wolltest Du es in die Klammern davor setzen oder so?!?

Grüße
Reaperman

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

3 Monate 1 Woche her #12582 von #1-stony

Reaperman schrieb:

diddipoeler schrieb: Wie lautet denn die Internetseite ?
Wurde bootstrap installiert ?
Ansonsten bitte die Adminzugangsdaten an mich senden.


Hallo zusammen,

ich habe mir das Problem einmal genauer angeschaut. Das Problem liegt in der Datei /components/com_sportmanagement/models/project.php.
Ich habe geschaut was in meiner und der neueren Versionen für Unterschiede sind.

if ( !self::$_project && COM_SPORTSMANAGEMENT_SHOW_DEBUG_INFO )
{
$app->enqueueMessage(JText::_(__METHOD__.' '.__LINE__.' seasonid<br><pre>'.print_r(self::$seasonid,true).'</pre>'),'Error');
$app->enqueueMessage(JText::_(__METHOD__.' '.__LINE__.'<br><pre>'.print_r($db->getErrorMsg(),true).'</pre>'),'Error');
}


}
Zeile 373-> //$db->disconnect(); // See: api.joomla.org/cms-3/classes/JDatabaseDr...ml#method_disconnect
return self::$_project;
}

Ich habe die Zeile 373 auskommentiert und seitdem werden die Ergebnisse wieder super schnell angezeigt. Vielleicht wolltest Du es in die Klammern davor setzen oder so?!?

Grüße
Reaperman


Hallo,

entschuldige, dass ich mich hier einmische.

Wenn eine Datenbankverbindung geöffnet wurde, was am Anfang des model project gemacht wird (Zeile 281), muss diese auch wieder geschlossen werden. Ansonsten wird mysql über kurz oder lang die Arbeit einstellen.

Langer Rede kurzer Sinn - die von dir angesprochene Zeile hat Sinn - die Datenbankverbindung wird geschlossen.

Das langsame Laden der Seite hat mit dieser Zeile nichts zu tun.

Siehe meinen Kommentar: fussballineuropa.de/index.php/forum?view...=4574&start=12#12577 .

Am Ende der Woche wird es sicher diesbezüglich von diddi eine offizielle Lösung im GitHub geben.
Ansonsten mal meine Testversion über JSM drüber installieren und testen!
Folgende Benutzer bedankten sich: svdoldie

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.958 Sekunden